Services unavailable
Incident Report for Tenant Turner
Resolved
We appreciate your patience during this system outage. Everything is resolved and you should have full access to the site at this time.
Posted Sep 06, 2024 - 11:05 EDT
Identified
We are aware of a wide scale system outage. During this time you may not be able to login to your account and will see an 'Our services aren't available right now' error page. The team is working towards a swift resolution.

Currently scheduled appointments will not be affected but leads my experience delays or slowness while scheduling.
Posted Sep 06, 2024 - 09:37 EDT
This incident affected: Tenant Turner.