Connectivity slowness
Incident Report for Tenant Turner
Resolved
Systems have returned to normal operating capacity.
Posted Jul 13, 2021 - 09:36 EDT
Update
We are continuing to investigate this issue.
Posted Jul 13, 2021 - 09:34 EDT
Update
We received communication from Microsoft that multiple of their hosting customers are having similar server connectivity issues. We continue to monitor.
Posted Jul 12, 2021 - 14:08 EDT
Investigating
We are seeing slow server responsiveness and connectivity delays. Customers have reported receiving "This site can't be reached" messages. We are investigating and will provide updates as they are available.
Posted Jul 12, 2021 - 12:51 EDT
This incident affected: Tenant Turner.