Phone System outage 10/22/25

Incident Report for Tenant Turner

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 16:17 EDT

Investigating

The Tenant Turner Customer Success team has received reports of outages for both phone calls and outbound text messages, including Self-Access lockbox code delivery, this afternoon 10/22/25. Our team is working closely with our engineers and our phone carrier to learn more and resolve the issue.
Posted Oct 22, 2025 - 15:11 EDT
This incident affected: Tenant Turner, CodeBox, and SentriLock.