We are happy to say that all issues related to yesterday's outage are resolved. If you continue to notice problems accessing the site please email Support@tenantturner.com with details.
Posted Apr 16, 2026 - 09:34 EDT
Monitoring
Further investigation has found this is related to a Microsoft Azure outage. Updates have been made and we are monitoring the situation before classifying this as resolved. If you continue to experience issues accessing your account please reach out to support@tenantturner.com.
Posted Apr 15, 2026 - 13:54 EDT
Investigating
Thanks for reaching out. We are currently experiencing a partial outage that is not affecting all customers, but may be affecting you. We are actively investigating to learn the scope and find a resolution. We will let you know once we have more information or the issue is resolved. For a status update, please visit an be sure to subscribe!